Degraded connectivity on all environments

Incident Report for Ironclad Contract Management

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:15 PDT

Monitoring

All functionality affected by the incident is now operational. We are monitoring for any further issues.
Posted Jun 12, 2025 - 13:46 PDT

Identified

All Ironclad environments are experiencing degraded connectivity and processing times starting at 11:03 am due to issues with our upstream cloud providers.
Posted Jun 12, 2025 - 11:03 PDT
This incident affected: North America (NA1) (Workflows, Repository), Europe (EU1) (Workflows, Repository), and Ironclad Dependencies (mailgun API, mailgun SMTP, mailgun Outbound Delivery, mailgun Inbound email processing, Google Cloud Platform Google Cloud Storage, Google Cloud Platform Google Cloud SQL, Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Cloud DNS, Google Cloud Platform Cloud Filestore, Google Cloud Platform Cloud Key Management Service).