Site performance problems with signature collection
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
If you were attempting to upload a signed contract during this time period, please try uploading again. If you continue to have issues, please contact support@ironcladhq.com.
Posted Oct 04, 2021 - 15:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2021 - 12:49 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 04, 2021 - 10:58 PDT
Investigating
Ironclad is currently experiencing issues with the signature collection function. We are investigating and will provide regular updates.
Posted Oct 04, 2021 - 10:41 PDT
This incident affected: Europe (EU1) (Workflows, Repository) and North America (NA1) (Workflows, Repository).