Intermittent issues with Dashboard and Repository
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Apr 14, 2023 - 13:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2023 - 12:51 PDT
Investigating
We are currently investigating this issue.
Posted Apr 14, 2023 - 11:59 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2023 - 09:38 PDT
Investigating
We are currently investigating issues pertaining to dashboard filters and completed records not appearing in the repository
Posted Apr 14, 2023 - 07:36 PDT
This incident affected: North America (NA1) (Workflows, Repository).