Ironclad is experiencing latency and issues with completing any updates within the workflow (emails, approvals, reassignments)
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Apr 26, 2023 - 17:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2023 - 14:46 PDT
Investigating
We are currently investigating this issue.
Posted Apr 26, 2023 - 14:06 PDT
This incident affected: North America (NA1) (Workflows) and Europe (EU1) (Workflows).