Ironclad is experiencing a services disruption
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 06:11 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2020 - 06:00 PDT
Investigating
We have identified that some users are unable to sign in and are receiving an "Invalid csrf token" message when trying to. We are currently investigating this issue.
Posted Jun 26, 2020 - 05:55 PDT
This incident affected: North America (NA1) (Workflows, Repository).