Site performance problems
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 12:05 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2020 - 11:27 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 21, 2020 - 11:15 PST
Investigating
Ironclad is currently experiencing slow load times and general degraded performance. We are investigating the cause.
Posted Dec 21, 2020 - 11:10 PST
This incident affected: Workflows and Repository.