Experiencing issues with service provider Google Drive
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Dec 06, 2019 - 13:29 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2019 - 12:50 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 06, 2019 - 12:42 PST
Investigating
We are experiencing instability due to an issue with the service provider Google Drive. If you are integrated with Google Drive in Ironclad you will mostly likely be affected. We are currently looking into the issue and will update accordingly.
Posted Dec 06, 2019 - 11:08 PST
This incident affected: North America (NA1) (Workflows, Repository).