Note: Individual customers may or may not be affected by the downtime displayed on this page. Ironclad customers must be directly impacted by downtime in order to be eligible for service credits pursuant to a customer’s Agreement with Ironclad.
Resolved
This incident has been resolved. We'll continue to monitor closely.
Monitoring
Infrastructure enhancements have been implemented to mitigate latency and increase request processing efficiency.
Investigating
Our investigation into the latency issues is ongoing. We have worked to organize the required teams and resources and have made this a critical priority. We will continue to monitor and provide updates as they are available.
Investigating
We are actively investigating increased latency and slow loading times across workflows and dashboard pages in Ironclad. Some users may find delays when accessing or submitting workflows.
We are actively working to identify the root cause and implement a fix as quickly as possible.