Ironclad is experiencing an outage
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Jan 18, 2019 - 11:17 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 18, 2019 - 10:09 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2019 - 09:47 PST
Investigating
We are currently investigating this issue.
Posted Jan 18, 2019 - 09:03 PST
This incident affected: Workflows and Repository.