Ironclad is experiencing a service disruption
Incident Report for Ironclad Contract Management
Resolved
Confirmed resolution of this incident.
Posted Apr 10, 2020 - 07:10 PDT
Monitoring
A fix has been implemented, the incident has been resolved, we are continuing to monitor the results.
Posted Apr 10, 2020 - 07:00 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 10, 2020 - 06:40 PDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2020 - 23:00 PDT
This incident affected: Workflows and Repository.