Site performance
Incident Report for Ironclad Contract Management
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 12:30 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 13, 2020 - 12:08 PDT
Monitoring
A fix has been implemented and performance should be improved.
Posted Oct 13, 2020 - 12:07 PDT
Update
We are continuing to investigate the cause of the slow load times.
Posted Oct 13, 2020 - 11:04 PDT
Investigating
Ironclad is currently experiencing slower than normal load times. We are investigating the cause.
Posted Oct 13, 2020 - 10:04 PDT
This incident affected: Workflows and Repository.